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Getting Started
Creating TencentDB for SQL Server Instance
Last updated：2024-01-18 17:16:54

Overview

This document describes how to create an instance in the TencentDB for SQL Server console.

Prerequisites   

You have registered a Tencent Cloud account and completed identity verification. For more information, see Signing 
Up and Identity Verification Guide.

Directions

Creating an instance   

1. Go to the TencentDB for SQL Server purchase page, complete the configurations in Select a basic 
configuration, Set network and database, and
Confirm the configuration info. Then, read and indicate your consent to the Terms of Service, confirm that 
everything is correct, and click Buy Now.

Step 1. Select a basic configuration


In this step, you can set the basic configuration and specification options for the instance. The specific settings are as 
follows:
Basic Configuration
Billing Mode: Pay-as-you-go.  
Region: We recommend that you choose the region closest to your end users to minimize access latency and improve 
download speed.

AZ: Select an AZ in the selected region. You can also use the AZ that is randomly allocated by the system.
Instance Architecture: The instance is on a single-node or two-node architecture.
Storage Type:
When single-node architecture is selected, you can choose from premium cloud disk, SSD, balanced SSD, and 
enhanced SSD.

Note:

https://www.tencentcloud.com/document/product/378/17985
https://www.tencentcloud.com/document/product/378/3629
https://buy.tencentcloud.com/sqlserver#/
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In the Chinese mainland, if you need SSD for your basic edition instances, submit a ticket for application.
When two-node architecture is selected, you can choose from enhanced SSD, balanced SSD, and high-performance 
local SSD.


 For a detailed description of each storage type and applicable scenarios, see Storage Types.
Database Version: supports SQL Server 2008 R2, SQL Server 2012, SQL Server 2014, SQL Server 2016, SQL 
Server 2017 and SQL Server 2019 Enterprise and Standard version as well as SQL 2022 Enterprise version.
Specs Configuration
Type: The Dedicated type is supported.

Filter: You can quickly filter the needed CPU and memory specifications for the instance. By default, all CPU and 
memory specifications are selected.
Selected instances: The specification information of the selected instances are displayed, including specification type 
and specification.
Instance Specifications: The detailed specification information is displayed, including the specification type, CPU, 
memory, maximum IOPS, supported AZs, and reference fees.

Storage Space: Select the required disk capacity.
Step 2. Set network and database
Network: VPC is supported. For connectivity testing, see Network Environment. Both VPCs and subnets support fuzzy 
search.
Note:

We recommend that you place the CVM and TencentDB instances under the same account in the same VPC in the 
same region.
A subnet is a logical network space in a VPC. You can create subnets in different AZs in the same VPC, which 
communicate with each other over the private network by default. Even if you select a subnet in another AZ in the 
same region, the network latency will not be increased because the actual business connection adopts nearby access.

Security Group: A security group is a stateful virtual firewall capable of filtering. As an important means for network 
security isolation provided by Tencent Cloud, it can be used to set network access controls for one or more 
TencentDB instances.
Note:
You can either create new security groups or choose from existing ones. You can also locate the target group by fuzzy 
search.

Instance Name: Select Set After Creation or Set Now.
Multi-AZ Deployment: If Yes is selected, it means that the multi-AZ Deployment is set, and the backup AZ should be 
selected in the next step; if No is selected, it indicates that there is no need to perform the multi-AZ deployment. The 
multi-AZ is a physical zone integrating multiple single-AZs in the same region at the single AZ level to protect the 
database from the potential instance failure or AZ interruption.

Replica AZ: After multi-AZ deployment is selected, you need to select the replica AZ based on the actual optional 
resources.
System Time Zone: China Standard Time (Beijing Time) is supported by default.

https://console.tencentcloud.com/workorder/category
https://www.tencentcloud.com/document/product/238/46490
https://www.tencentcloud.com/document/product/238/32562
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For the purchase of the two-node local disk instances, submit a ticket to apply for the modification of the system time 
zone.
For the purchase of the single-node cloud disk or two-node cloud disk instances, the system time zone can be directly 

modified without application.
Sorting Rules of Character Set: The instance character set provides sorting rules for system data, namely, 
distinguishing between case-sensitive attributes and accent attributes. The Chinese_PRC_CI_AS is supported by 
default.
If a two-node local disk instance is purchased, submit a ticket to apply for the modification of the rules for the 

character set.
If a single-node cloud disk or two-node cloud disk instance is purchased, the rules can be modified directly without 
application.
Project: TencentDB for SQL Server supports assigning instances to different projects for management. You can 
perform fuzzy search for projects by name.
Tag: You can use tags to easily categorize and manage resources. You are allowed to add multiple tags.

Maintenance Window/Maintenance Time: The backend system performs maintenance operations on your TencentDB 
for SQL Server instance from time to time to ensure its stability. To minimize the potential impact on your business, we 
recommend that you set an acceptable maintenance period for your business instance, usually during off-peak hours. 
You can select up to all the seven options for the maintenance windows.
Step 3. Confirm the configuration info

Display the instance configuration details in Step 1 and Step 2. Click Edit directly in case of modification. After 
confirmation of the result, read and check Terms of Service, and then click on Buy Now.   
Terms of Service: For more information, see Terms of Service.

2. Return to the Instance List after purchase and view the created instances. When the instance status is Running, 
the instance is successfully created.

Creating an account

1. In the instance list, click an instance ID or Manage in the Operation column to enter the instance management 
page.
2. On the instance management page, select Account Management > Create Account and enter relevant 
information in the pop-up window. After confirming that everything is correct, click OK.

https://console.tencentcloud.com/workorder/category
https://console.tencentcloud.com/workorder/category
https://www.tencentcloud.com/document/product/238/35546
https://console.tencentcloud.com/sqlserver#/
https://console.tencentcloud.com/sqlserver
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Note:
The created account name and password will be used when connecting to TencentDB for SQL Server. Store them 
properly.

Creating a database

1. In the instance list, click an instance ID or Manage in the Operation column to enter the instance management 
page.
2. On the Instance Management page, select Database Management > Create Database, set configuration 
items in the pop-up window, confirm that everything is correct, and click OK.
Database Name: It can contain up to 32 letters, digits, and underscores and must start with a letter.

Character Set: Select the character set to be used by the database. Currently, most native character sets are 
supported.
Authorize Account: You can authorize existing accounts to access the database. If you haven't created an account yet,
see Creating an account.
Remarks: Enter remarks of up to 256 characters.

https://console.tencentcloud.com/sqlserver
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Connecting to TencentDB for SQL Server
Instance
Instance Connection Scenarios
Last updated：2024-01-18 17:16:54

This document describes some scenarios and methods of connecting to a TencentDB for SQL Server instance from a 
Windows CVM instance or local Windows system through SQL Server Management Studio (SSMS). For detailed 
directions, see Connecting to TencentDB for SQL Server Instance from Windows CVM Instance and Connecting to 

TencentDB for SQL Server Instance from Local System.

Connecting to a TencentDB for SQL Server Instance from a 
Windows CVM Instance

Scenario 1

The CVM and TencentDB for SQL Server instances are in the same VPC or classic network in the same region under 
the same Tencent Cloud root account.

Example: Under account 1, the CVM instance is in subnet A in VPC 1 in Guangzhou region, and the TencentDB for 
SQL Server instance is in subnet B in VPC 1 in Guangzhou region.


Connection method: Connect them over the private network.

Scenario 2

The CVM and TencentDB for SQL Server instances are in different VPCs in the same region under the same Tencent 
Cloud root account.

Example: Under account 1, the CVM instance is in subnet A in VPC 1 in Guangzhou region, and the TencentDB for 
SQL Server instance is in subnet B in VPC 2 in Guangzhou region.

Connection method: We recommend that you connect them through CCN.

Scenario 3

The CVM and TencentDB for SQL Server instances are in different regions under the same Tencent Cloud root 
account.

Example: Under account 1, the CVM instance is in subnet A in VPC 1 in Guangzhou region, and the TencentDB for 
SQL Server instance is in subnet B in VPC 2 in Beijing region.

Connection method: We recommend that you connect them through CCN.

https://www.tencentcloud.com/document/product/238/11626
https://www.tencentcloud.com/document/product/238/11627
https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/1003/31985
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Scenario 4

The CVM and TencentDB for SQL Server instances are under different Tencent Cloud root accounts.

Example: The CVM instance is in subnet A in VPC 1 in Guangzhou region under account 1, and the TencentDB for 
SQL Server instance is in subnet B in VPC 2 in Beijing region under account 2.


Connection method: We recommend that you connect them through CCN.

Connecting to a TencentDB for SQL Server Instance from a Local 
Windows System

Two-node (formerly High Availability/Cluster Edition) instance

Option 1: Use VPN, or Direct Connect, or CCN for interconnection, which are more secure and stable.
Option 2: Connect to the instance over the public network by enabling the public network address or binding the 
instance to CLB to enable public network access in the console as instructed in Connecting to TencentDB for SQL 
Server Instance from Local System.

Option 3: Use a Linux CVM instance with a public IP to map the ports as instructed in Connecting to TencentDB for 
SQL Server Instance from Local System.

Single-node (formerly Basic Edition) instance

Option 1: Use VPN, or Direct Connect, or CCN for interconnection, which are more secure and stable.
Option 2: Connect to the instance over the public network by enabling the public network address in the console as 
instructed in Connecting to TencentDB for SQL Server Instance from Local System.
Option 3: Use a Linux CVM instance with a public IP to map the ports as instructed in Connecting to TencentDB for 

SQL Server Instance from Local System.

https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/1037/32679
https://www.tencentcloud.com/document/product/216/7557
https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/238/11627
https://www.tencentcloud.com/document/product/238/11627#WWIPLJSL
https://www.tencentcloud.com/document/product/1037/32679
https://www.tencentcloud.com/document/product/216/7557
https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/238/11627#kqwwdz
https://www.tencentcloud.com/document/product/238/11627#WWIPLJSL
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Connecting to TencentDB for SQL Server
Instance from Windows CVM Instance
Last updated：2024-01-18 17:16:54

Overview

This document describes how to connect to a TencentDB for SQL Server instance through SQL Server Management 
Studio (SSMS) on a Windows CVM instance and run a simple query.
Note: 

The CVM and TencentDB instances are better to be under the same account and in the same VPC in the same 
region.
CVM and TencentDB instances in the same VPC in different AZs in the same region can directly interconnect through 
private IPs.
CVM and TencentDB instances in different regions or VPCs or under different accounts can interconnect through 

Peering Connection or CCN.

Directions

1. Log in to the TencentDB for SQL Server console, click an instance ID to enter the instance details page, and view 
the private IP and port number of the instance, which will be used for connecting to the TencentDB instance.


2. Log in to the Windows CVM instance. For more information, see Customizing Windows CVM Configurations. This 
document uses Windows Server 2012 R2 Standard Edition (64-bit) as an example.

https://www.tencentcloud.com/document/product/553/18836
https://www.tencentcloud.com/document/product/1003/31985
https://console.tencentcloud.com/sqlserver
https://www.tencentcloud.com/document/product/213/10516
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3. Download and install SQL Server Management Studio (SSMS) on the Windows CVM instance. For more 
information on SSMS, see What is SQL Server Management Studio (SSMS)?.
4. Start SSMS in the Windows CVM instance. On the Connect to server page, enter the relevant information to 

connect to TencentDB. Click Connect and wait a few minutes before SSMS connects to your database instance.
Server type: Select Database Engine.
Server name: Enter the private IP and port number of the instance and separate them by comma. For example, if the 
private IP of the instance is  10.10.10.10  and the port number is  1433 , then enter  10.10.10.10,1433  

here.

Authentication: Select SQL Server Authentication.
Login and Password: Enter the account name and password you configured when creating the instance account on 
the Account Management page.


5. Once connected to the database, you can view the standard built-in system databases (master, model, msdb and 
tempdb) of SQL Server.


https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms
https://docs.microsoft.com/en-us/sql/ssms/sql-server-management-studio-ssms?view=sql-server-ver15
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6. You can start creating your own databases and running queries for them. Select File > New > Query with Current 
Connection and type the following SQL query:
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select @@VERSION

Run the query. SSMS returns the TencentDB for SQL Server instance.
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Connecting to TencentDB for SQL Server
Instance from Local System
Last updated：2024-01-18 17:16:54

This document describes how to connect to a TencentDB for SQL Server instance through SQL Server Management 
Studio (SSMS), and run a simple query.

Connection scenarios

The connection methods vary by TencentDB instance type:


You can connect to a two-node TencentDB for SQL Server instance (formerly high-availability edition/cluster editions) 
from a local system in the following three methods:
Option 1: Use VPN, or Direct Connect, or CCN for interconnection, which are more secure and stable.
Option 2: Connect to the instance over the public network by enabling the public network address or binding the 
instance to CLB to enable public network access in the console.

Option 3: Use a Linux CVM instance with a public IP to map the ports.
You can connect to a single-node TencentDB for SQL Server instance (formerly basic edition) from a local system in 
the following three methods:
Option 1: Use VPN, or Direct Connect, or CCN for interconnection, which are more secure and stable.
Option 2: Connect to the instance over the public network by enabling the public network address in the console.
Option 3: Use a Linux CVM instance with a public IP to map the ports.

The following are connection options:
Enabling the public network address in the console and connecting to the TencentDB for SQL Server instance from a 
local system through SSMS.
Binding the TencentDB for SQL Server instance to CLB and connecting to the instance from a local system through 
SSMS.

Using a Linux CVM instance with a public IP to map the ports and connecting to the instance from a local system 
through SSMS

Enabling the public network address in the console and connecting 
to the TencentDB for SQL Server instance from a local system 
through SSMS

Step 1. Enable the public network address

https://www.tencentcloud.com/document/product/1037/32679
https://www.tencentcloud.com/document/product/216/7557
https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/1037/32679
https://www.tencentcloud.com/document/product/216/7557
https://www.tencentcloud.com/document/product/1003/31985
https://www.tencentcloud.com/document/product/238/11627
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1. Log in to the TencentDB for SQL Server console.
2. Select the region and click the ID or Manage in the Operation column of the target instance in the instance list.
3. On the Instance Details page, click Enable in Basic Info > Public Address.

4. In the Enabling public network window, read the note, indicate your consent, and click OK.
5. After public network access is enabled, view the public IP address and port number of the instance in Basic Info 
on the Instance Details tab.
Note: 
For the detailed notes and steps of enabling public network access, see Enabling/Disabling Public Network Address.

Step 2. Connect to the TencentDB for SQL Server instance over the public network

1. Download and install SQL Server Management Studio locally. For more information on SSMS, see Using SQL 
Server Management Studio.
2. Start SSMS locally. On the Connect to server page, enter the relevant information to connect to TencentDB. Click 
Connect and wait a few minutes before SSMS connects to your database instance.
Server type: Select Database Engine.
Server name: Enter the public IP address and port number of the instance and separate them by comma.

Authentication: Select SQL Server Authentication.
Login and Password: Enter the account name and password you configured when creating the instance account on 
the Account Management page.


3. Once connected to the database, you can view the standard built-in system databases (master, model, msdb and 

tempdb) of SQL Server.


https://console.tencentcloud.com/sqlserver
https://www.tencentcloud.com/document/product/238/50230
https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-ver16
https://docs.microsoft.com/en/sql/ssms/sql-server-management-studio-ssms?view=sql-server-ver15
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4. Now you can start creating your own databases and running queries for them. Select File > New > Query with 
Current Connection and type the following SQL query:
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select @@VERSION

Run the query. SSMS returns the TencentDB for SQL Server instance.
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Binding the TencentDB for SQL Server instance to CLB to enable 
public network access and connecting to the instance from a local 
system through SSMS

Step 1. Purchase a CLB instance

Note: 
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If you already have a CLB instance in the same region as TencentDB for SQL Server, skip this step.
Go to the CLB purchase page, select the configuration, and click Buy Now.
Note: 

Region: You need to select the region where the TencentDB for SQL Server instance is.
Network: You can select the same VPC as the instance or a different one.

Step 2. Configure CLB Configuration

1 Enable cross-VPC access (you can skip this step if the CLB instance and TencentDB for SQL Server instance are in 
the same VPC)

a. Log in to the CLB Console, select the region, and click the instance ID in the instance list to enter the management 

page.

b. On the Basic Info page, click Configure in the Real Server section.
c. In the pop-up window, click Submit.
1. Configure a public network listener port

a. Log in to the CLB Console, select the region, and click the instance ID in the instance list to enter the management 
page.


b. On the instance management page, select the Listener Management tab and click Create below TCP/UDP/TCP 
SSL Listener.


c. In the pop-up window, complete the settings and click Submit.


https://buy.tencentcloud.com/clb
https://console.tencentcloud.com/clb/instance
https://console.tencentcloud.com/clb/instance
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Step 3. Bind a TencentDB for SQL Server instance

1 After creating the listener, click it in Listener Management and click Bind on the right.


2 In the pop-up window, select Other Private IPs as the object type, enter the IP address and port of the TencentDB 
for SQL Server instance, and click OK.
Note: 
The login account must be a standard account (bill-by-IP). If binding fails, submit a ticket for assistance.

Step 4. Configure the TencentDB for SQL Server security group

1. Log in to the TencentDB for SQL Server console. Select a region, click an instance ID in the instance list or 

Manage in the Operation column to access the instance management page.

https://console.tencentcloud.com/workorder/category
https://console.tencentcloud.com/sqlserver
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2. On the instance management page, select the Security Group tab, click Configure Security Group, configure 
the security group rule to open all ports, and confirm that the security group allows access from public IPs. For more 
information on configuration, see Configuring Security Group.

Step 5. Connect to the TencentDB for SQL Server instance over the public network

1. Download and install SQL Server Management Studio locally. For more information on SSMS, please see Using 
SQL Server Management Studio.
2. Start SSMS locally. On the Connect to server page, enter the relevant information to connect to TencentDB. Click 
Connect and wait a few minutes before SSMS connects to your database instance.
Server type: Select Database Engine.

Server name: Enter the local IP address and port number of the CLB instance and separate them by a comma, such 
as  10.0.0.1,4000 .

Authentication: Select SQL Server Authentication.
Login and Password: Enter the account name and password you configured when creating the instance account on 
the Account Management page.


3. Once connected to the database, you can view the standard built-in system databases (master, model, msdb and 
tempdb) of SQL Server.


https://www.tencentcloud.com/document/product/238/35789
https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms?view=sql-server-ver16
https://docs.microsoft.com/en/sql/ssms/sql-server-management-studio-ssms?view=sql-server-ver15


TencentDB for SQL Server

©2013-2022 Tencent Cloud. All rights reserved. Page 23
of 34

4. Now you can start creating your own databases and running queries for them. Select File > New > Query with 
Current Connection and type the following SQL query:
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select @@VERSION

Run the query. SSMS returns the TencentDB for SQL Server instance.
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Using a linux CVM instance with a public IP to map the ports and 
connecting to the instance from a local system through SSMS

Note: 
The CVM and TencentDB instances must be under the same account and in the same VPC in the same region.

For data security considerations, TencentDB for SQL Server doesn't support public IP. If you need to use a public IP, 
you can use the port mapping feature of SSH2 to connect to, configure, and manage an instance from the internet.
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1. Log in to the TencentDB for SQL Server console. On the instance details page, view the private IP and port number 
of the instance, which will be used for configuring port mapping.


2. Prepare a Linux-based CVM instance with a public IP. For more information , see Customizing Linux CVM 
Configurations.
3. Log in to the Linux CVM instance locally with an SSH tool such as SecureCRT (as demonstrated in this document). 
For the login method, see Logging in to Linux Instance (Web Shell).
4. Select Options > Session Options in the SecureCRT menu bar to enter the session properties settings.


https://console.tencentcloud.com/sqlserver
https://www.tencentcloud.com/document/product/213/10517
https://www.tencentcloud.com/document/product/213/5436
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5. On the session properties settings page, select Connection > Port Forwarding > Add to enter the port mapping 
configuration page.


6. On the port mapping configuration page, configure the corresponding parameters.
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7. Download and install SQL Server Management Studio (SSMS) locally. For more information on SSMS, see Use 
SQL Server Management Studio.

8. Start SSMS locally. On the Connect to server page, enter the relevant information to connect to TencentDB. Click 
Connect and wait a few minutes before SSMS connects to your database instance.
Server type: Select Database Engine.
Server name: enter the local IP address and port number and separate them with a comma, such as 
 10.0.0.1,4000 . The port number should be the same as that configured in step 6.

Authentication: Select SQL Server Authentication.
Login and Password: Enter the account name and password you configured when creating the instance account on 
the Account Management page.


https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-management-studio-ssms
https://docs.microsoft.com/en/sql/ssms/sql-server-management-studio-ssms?view=sql-server-ver15
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9. Once connected to the database, you can view the standard built-in system databases (master, model, msdb and 
tempdb) of SQL Server.
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10. Now you can start creating your own databases and running queries for them. Select File > New > Query with 
Current Connection and type the following SQL query:

select @@VERSION

Run the query. SSMS returns the TencentDB for SQL Server instance.
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Managing TencentDB for SQL Server
Instance
Last updated：2024-01-18 17:16:54

Instance List Page

Log in to the TencentDB for SQL Server console, and enter the instance list page to view the instance information and 
manage your instances.


Feature Description

Restart

In the instance list, select an instance and click Restart at the top to restart it. You can 
also select multiple instances for batch restart.
The instance will be inaccessible during the restart, and existing connections to it will be 
closed. 
If the number of business writes is high during the restart, the restart will fail. In this case, 
the instance will go back to the state before the restart and become accessible. 
Restart the instance during off-peak hours to ensure success and minimize the impact on 
your business.

Renewal In the instance list, select one or more target instances, click ** Renew** to renew them by 
month or year.

Setting auto-
renewal

In the instance list, select one or more target instances, and click More > Enable Auto-
Renewal to set monthly auto-renewal for them. After you click OK, the instances will be 
automatically renewed monthly upon expiration if your Tencent Cloud account balance is 
sufficient.

Disabling auto-
renewal

In the instance list, select one or more target instances marked with Renew before their 
name, click More > Disable Auto-Renewal, and click OK.

Tag editing You can click More > Edit Tag above the instance list or in the Operation column of an 
instance to manage its tags. If you haven't created a tag, you can click Tag Management 
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to create one.

Configuration 
adjustment

In the instance list, you can adjust the configuration of your database instance. Both 
instance upgrade and disaster recovery mode adjustment are supported. For more 
information, see Overview.

Publish/Subscribe
In the instance list, you can select More > Publish/Subscribe in the Operation column 
of an instance to perform publish/subscribe to meet the data replication and sync 
requirements of your business.

Termination/return In the instance list, you can select More > Terminate/Return to terminate/return a 
database instance. For more information, see Terminating Instance.

Pay-as-you-go to 
monthly 
subscription

You can switch the instances from pay-as-you-go to monthly subscription. In the instance 
list, click More > Pay-as-You-Go to Monthly Subscription in the Operation column, 
select renewal period, and click OK after reading the rules.

Read-Only 
Instance

In the instance list, you can click More > Read-Only Instance in the Operation column 
of an instance to view its read-only instances and configure the RO group. If there are no 
read-only instances, you can click Create after redirection to add one or more read-only 
instances.

Instance Management Page

Log in to the TencentDB for SQL Server console. In the instance list, click the instance ID or Manage in the 
Operation column to access the instance management page, where you can view its details, monitor it, and manage 
databases.


Feature Description

Instance On theInstance Detail tab, you can view and manage various information of your databases, 
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details including setting maintenance information and adding read-only instances in the instance 
architecture diagram.

System 
monitoring

On theInstance Monitorin tab, you can view the monitoring data of various core metrics of the 
current database. For more information, please see Monitoring Feature and Alarming Feature.

Backup and 
restoration

On the Backup and Restoration tab, you can query the backup and restoration records and 
create a backup and restoration task. Supported backup upload methods include uploading file 
and downloading file from COS, and supported restoration modes include full backup file, full 
backups + logs, and full backups + differential backups.

Subscription 
publication

On the Publish/Subscribe tab, you can create or delete one or more publish/subscribe linkage 
services.

Security 
group

On the Security Group tab, you can configure security groups for your databases. For more 
information, see Configuring Security Group.

Account 
management

On the Account Management tab, you can manage the administrator account, such as 
modifying permissions and resetting password. You can also create and delete accounts. For 
more information, see Creating Account.

Database 
management

On the Database Management tab, you can create, delete, and set permissions of databases. 
For more information, see Database Management.

Read-only 
instances

On the Read-Only Instance tab, you can create one or more read-only (RO) instances, which 
can be applied to read/write separation and one-primary-multiple-replica application scenarios 
to boost the read load capacity of your databases. For more information, see Read-Only 
Instance Overview.

Backup 
management

On the Backup and Restoration tab, you can manually create, download, and restore 
backups. You can also set scheduled backups, and perform rollbacks. For more information, 
see Backup Management.

Slow query 
log

On the Operation Log tab, you can download slow query logs.

Parameter 
settings

On the Parameter Configuration tab, you can view and modify certain parameters and query 
the parameter modification logs. For more information, see Parameter Configuration.
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